Fs_game is write protected

Launched any mod on cod4x dedicated server checked the console it said fs_game is write protected uninstall cod4 installed it again along with a fresh cod4x client and server and the mod. It still says fs_game is write protected any idea? Cause i just want to play with my friends.

The +set fs_game mods/blah must be in the startup command. If it is invoked in the config , you will get that error.

Im sorry really for asking these questions but anyways i did a clean install of the game and downloaded cod4x client and the server again and put my mods on the mods folder created a shortcut for cod4x dedicated server put in +fs_game mods/themodname then it still says its write protected?

Edit: I created my server.cfg file haven’t inserted anything about launching mods

You said this is dedicated server? If you are running this from your windows box and the game is installed in the “Program Files” directory, consider relocating the installation as that directory (including subdirectories) is protected and may not allow the game to write to it.

Well the game is on the desktop it still doesn’t and im really sorry for having you put up with these problems that i have.

Can you post your startup command?

Ok here it is
“C:\Users\End User\Desktop\Call of Duty 4 Modern Warfare\cod4x18_dedrun.exe” +set dedicated “1” +set sv_punkbuster “0” +set fs_game “mods/chaosmod” +exec server.cfg +map_rotate

Idk this shortcut worked before and now can’t launch any mods through the dev console. Idk if mod tools caused this but i could just launch mods normally before the mod tools. Does the mod tools create a folder which store files which may have prevented me from launching mods if yes where is it cause i have no idea what prevents me.

Please try this and let me know:
“C:\Users\End User\Desktop\Call of Duty 4 Modern Warfare\cod4x18_dedrun.exe” +set fs_game mods/chaosmod +set dedicated 1 +set sv_punkbuster 0 +exec server.cfg +map_rotate

What I did: Made sure that the fs_game is loaded first and cleaned up extra spaces and quotes.

It doesn’t work. The only thing i could think of is if there’s a file outside the games folder that cod4x can read which prevents me from launching mods also does cod4 mod tools create a folder outside the games folder itself. By the way my new installation of cod4 is on the C drive whilst cod4 with mod tools on it is on the D drive.

Ahhh ok. Maybe the game is calling the savepath incorrectly. Try specifying like so:

+set fs_game "mods/chaosmod" +set dedicated 1 +set net_ip xx.xx.xx.xx +set net_port 28960 +set fs_basepath /path/to/folder +set fs_homepath/path/to/folder +set fs_savepath/path/to/folder +set sv_punkbuster 0 +exec server.cfg +set rcon_password passwrd +set sv_maxclients 20 +map_rotate set sv_authorizemode -1

This is what I use on one of my testing server. Just fill in the IP, Port and change all path/to/folder entries to the place the game is installed.

Basepath and homepath write protected i already deleted the other cod4 on my d drive it still says its write protected

Ok so it is also write protected on vanilla cod4 not cod4x only