How to install and run Cod4x on Linux (Steam)

This worked on my setup, while it may not work on others. Bear that in mind.

Download the cod4x files from the the downloads on this site, extract the files into the mods folder of your call of duty 4 installation. Then run “wine install.cmd” in your terminal after cding into the correct directory.

Go into the .wine folder in your home directory and navigate to your user account and to AppData. Copy the Call of Duty 4 Modern Warfare file folder that contains important data (I forgot what it exactly is for but found when I removed it and ran it without steam, it didn’t show up as Cod4X anymore and instead just as 1.7 and had no more access to cod4x servers). Go to steamapps, then to compatdata I think, then into the wineprefix folder proton automatically created for the game (for me it was called 7940 since that is the app id), then paste it into the AppData folder of that. Now when booting up the game, it should run perfectly and now support Cod4x servers.


When running wine install.cmd it did not do anything.

It outputted: not supported on this system

Are you in the Cod4x mod folder directory? If so, I don’t think I know how to help. Maybe use a different version of wine? My computer’s default one is 8.1 currently.

Okay maybe I will have to wait for a newer LTS to come (tomorrow), because mine is on 6.0.3.

I am soon changing to a rolling release because of things like this.

Anyway, thanks. I will let you know if it works.

I tried to fix it, ran the game through Lutris (I have the DVD copy of it). Now it just says that it requires Steam for the multiplayer, which I do not understand. Why make a disc copy if you do not support multiplayer on it?