Issues connecting to server remotely

Hi Everyone,

I had a server running for a while and it’s been fine, now more recently, I’ve been unable to connect to it remotely.

I don’t use the master server tokens, though when I was testing things to try to fix it I did use it and it appeared in the list. It correctly shows player count, map and game type in the listing (and when we access it from favorites) however we’re unable to join, when joining it gets stuck on “Setting up game…” which usually eventually (after a few mins) times out.

The server is showing that the client has connected and been validated through steam but then just sits there until the client connection times out.

This isn’t an issue with clients on the same network (or using network bridging sotware like radmin/tailscale) who can connect and play without issue.

I have checked my port forwarding and it is correct (supported by the game listing the server).

I’ve tried setting up the server a few different ways, it’s currently running on a ubuntu VM but I’ve tried running it on windows and in docker and always hit the same issue. I even tried setting it up in AWS and had the same problem. A friend is able to duplicate the issue when setting up a server.

I’m sure we’re just missing a step but I don’t really know what we’re missing. Any ideas?

TIA

Please give more info about the setup:

  1. Are you on a windows system and running the server on an Ubuntu server VM?
  2. Is this being run in a LAN environment?
  3. Are all connecting players updated to latest CoD4X client (and are you properly updated) ?

I’ll try to help you as best I can.

Cheers.

Hi,

  1. Yes I am running windows for the clients but the server is running on a ubuntu VM, we also tried on Windows VMs and experienced the same issues.
  2. The problem does not occur in a LAN environment but does occur when users connect remotely. I don’t believe this is a firewall/port forwarding issue though as I can see the games remotely (which would not be possible if the ports were not forwarded/open) and can even make an initial connection.
  3. I assume so as we’re able to connect to the server on the LAN side.

Ah I see, I suspect it is a port conflict. Your VM is using the ports you are trying to connect with…example: VM is using port 28961, therefore the host system is locking that port for the VM and then the game is trying to use it for the connect. Try using a wildly different port for the server, like 28999. Don’t forget to port forward that one too.

Good luck.

Hey,

Unfortunately, I don’t think this is it either, I have tried various ports and as I mentioned in the original post, I’m hosting from a different physical computer (even the VM is on a different computer). In addition it doesn’t explain why it works on the local computer but not through the internet.

Thanks for the suggestions though.

Then your VM software isn’t configured properly. Make sure the VM is properly set up to use your network adapter. What VM software are you using?

I’m using proxmox as the hypervisor with a ubuntu guest OS. The adaptor is set correctly, if it weren’t I shouldn’t be able to connect from the local network correct?

No, your host will allow connection through the virtual adapter, but the hardware adapter may not be configured properly for the VM to use and therefore no direct internet connection.