Steam’s api dll doesn’t initialise

Hi, recently we’re having trouble with our servers.
Apparently the Steam’s api dll doesn’t initialise properly and all the players are assigned playerid 0.

num score ping guid                             name            lastmsg address               qport rate
--- ----- ---- -------------------------------- --------------- ------- --------------------- ----- -----
 10     0   71 0                                MB VALOHAWK          50     6478 25000

These three lines are now missing in qconsole.log:

Steam: Server connected successfully
GameServer is not VAC Secure!
GameServer SteamID: [...]

This applies to all players, whether they connect with or without Steam.
I have no idea why it’s happening

I do not see this problem on my servers

Have you tried extracting the server files again over your existing to replace them in case there is a corrupted file(s).

Do you mean

I mean the full cod4x server files

Ok I fixed it. Basically the server’s startup script (like was executed by another process (a discord bot) with a different working directory. Aligning the two working directories solved the issue.

Glad to see you sorted it :+1:

I’m also having this trouble. I will look into it later and post if the problem is similar.

Still inconsistent…I use NeHo’s webadmin for Steam authentication to admin…but I am coming up as having insuffcient power (sometimes, but most of the time).

No good for me :frowning: I have gotten a new API Key from Steam to use for the site (webadmin) restarted and done all but I am not getting authenticated…NO idea whats going on. Steam is running and linked to meand I can see my Steam ID in webadmin. Webadmin has not been chnaged or updated in any way so is it CoD4X side…No idea :slight_smile:

Anyone else using the Webadmin from NeHo ?

Its been a while so maybe I am missing something :slight_smile: