Why can't I play Cod4 without steam after the new release(cod4x_client_21_1)?

This is the error I am getting. Please find the below photo. Is it mandatory to install Cod4 on Steam in order to play on Cod4X servers right now?

I don’t have steam version and mine plays just fine

1 Like

Mine doesn’t work. Maybe the problem is I am on Linux but there might be a workaround for that.

Unfortunately, since their latest changes, steam does not have the latest update for cod4x and you have to download the latest cod4x update yourself.

Releases You can find here cod4x client

There is really hacky ways to get that aroud, so much easier to get it on steam from 3 party cdkey sites, then literally 1 click install, join one of the servers, update rhe client, and you golden.

I thought he was asking if he needed the steam version to play cod4x as he doesn’t have the steam version and not how to get the steam version to work.

Maybe I misread it but it appears that what he was asking

plZz HelP me how can i download cod4x cielent 21.1 version

Everything is provided on this website if you take the time to look

but here is a quick link to what you are looking for:


maybe make a separate button and close this issue? :wink:

Don’t bump other people topics, use the search field.

1 Like

Could you at least elaborate on what those hacky workarounds are, for those that would rather not buy the game twice? I’ve tried running it as a non-Steam title as well and installed cod4x to that, but still no luck.

I already have a genuine CD key for the disc original, and would rather have the version I own work as it should, like it does on Windows. None of the other CoD private server solutions (for the other games, not exclusively CoD4) have this requirement, and work decidedly better as a result.

I couldn’t find a good way to get CoD4x up and running with steam correctly on Linux anywhere so I did it myself and made this tutorial to help the next guy. I made markup text version pull request on github as well HERE if you are interested. Hopefully it gets approved eventually. It is tricky now because you cannot just run modern warfare without steam when you join servers.

  1. Run the following command and the following ones in the Linux terminal to remove old wine if not on 5.0

sudo apt remove winehq-stable wine-stable wine1.6 wine-mono wine-geco winetricks

  1. Add support for 32 bit apps

sudo dpkg --add-architecture i386

  1. Download wine repository key

wget -qO - https://dl.winehq.org/wine-builds/winehq.key | sudo apt-key add -

  1. Add the downloaded repository key

sudo apt-add-repository "deb https://dl.winehq.org/wine-builds/ubuntu $(lsb_release -cs) main"

  1. Install Wine 5.0

sudo apt update && sudo apt install --install-recommends winehq-stable

  1. Now run this command to check your wine version. If it says 5.0 your good!

wine --version


  1. Your files will be installed in a hidden .wine folder Example : /home/USERNAME/.wine/drive_c


8 ) Download the windows steam install from steams website HERE.

  1. Go to your terminal and go to your download directory Replace USERNAME with your own and the name of the executable file. NEVER USE ROOT/SUPER USER FOR WINE COMMANDS!

cd /home/USERNAME/Downloads wine SteamSetup.exe

  1. If done right the steam install window will show up. Install Steam like normal. Delete the steam folder in the wine C drive as shown above if it already exists (WIne 5.0 creates this folder by default I think).


  1. After steam is done do these similar steps to install Call of Duty 4 Modern Warfare via wine. You first install Call of Duty 1.0 by going to the directory and run Wine Setup.exe like with steam and install it via the default directory. You do not have to install direct x so answer no for that.

cd /media/USERNAME/COD4MW wine Setup.exe


  1. Then you download and install patch 1.6 the same way (you have to wait 10+ minutes for it to load after click install - IT ALWAYS HANGS FOR 10 MINUTES JUST WAIT!)

cd /home/USERNAME/Downloads wine cod4mw-1.6-patchsetup.exe


  1. Download and Install patch 1.7 the same way but it shouldn’t hang.

cd /home/USERNAME/Downloads wine cod4mw-1.7-patchsetup.exe


13b) Download the cod4xme client files folder and place them in your Call of duty modern warfare folder. Example: /home/james/.wine/drive_c/Program Files (x86)/Activision


13c) Go to your cod4x18_v17_9_client folder directory and run the install.cmd script using the command interpreter with wine.

cd ‘/home/USERNAME/.wine/drive_c/Program Files (x86)/Activision/Call of Duty 4 - Modern Warfare/cod4x18_v17_9_client’ wine cmd.exe /C install.cmd


13d) If done correctly you should see the cod4x_017 files in “/home/YOURUSERNAME/.wine/drive_c/users/YOURUSERNAME/Local Settings/Application Data/CallofDuty4MW/bin/cod4x_017”


  1. Go to the C:/Program Files (x86) directory and Run steam via Wine 5.0**. You need to use special arguments “-no-cef-sandbox” or else Steams web forms will not load! ITS A STUPID BUG IN STEAM >.<.** Replace USERNAME with your own.

cd ‘/home/USERNAME/.wine/drive_c/Program Files (x86)/Steam’ wine Steam.exe -no-cef-sandbox

  1. Log into your steam account. If you do not have one CREATE ONE. You have no choice now if you want to play on the latest version sadly.


  1. If you ran wine with the correct arguments above you can actually see the Steam pages load as shown below.


  1. Click on Games → Add Non-Steam Game To Library


  1. Call of Duty 4 Modern Warfare Single Player and Multiplayer should show up. Select them both and click add selected programs.


  1. Go to Games → View Games Library


  1. Click on Call of Duty Multiplayer and click play. If you did it correctly you will see the steam overlay in the bottom right corner. Join a server with the 1.8 patch and it will update your client if you did not run the install.cmd script above (you have to run COD 1 or 2 times again the finalize the update). The install.cmd scrip with cod4x will not run correctly in wine. You have to place the files manually as shown above. It is easier to just join a cod4x server and update that way. The user name in your steam profile is the name you will see in game.


if its patched correctly you should see the following with 17.9 in the corner.


If you did not you will see this lovely Error loading Cod4X popup: “Failed to load CoD4X because file cod4x_xxx.dll or entry point was not found. Attempting to load Cod4 v1.7”. Its because it cannot find the application data folder in the right place based on your user name.


  1. Run steam via wine to play COD4x any time you want to via Steam. If your lazy you can configure it in via Lutris below.

cd ‘/home/USERNAME/.wine/drive_c/Program Files (x86)/Steam’ wine Steam.exe -no-cef-sandbox


sudo add-apt-repository ppa:lutris-team/lutris sudo apt-get update sudo apt-get install lutris

  1. Run Lutris via the applications portal. Click on the plus button → Add Game


  1. Enter the name of your program “Steam”. Select the Runner as Wine. You shouldn’t have to install specific runners since 5.0 is installed.


  1. Click on Game Options at the top. Find your steam executable location. replace USERNAME with your own if you copy paste the path below. Enter the arguments “-no-cef-sandbox” or STEAM PAGES WONT LOAD! Leave the Prefix architecture as Auto (default).

/home/USERNAME/.wine/drive_c/Program Files (x86)/Steam/Steam.exe -no-cef-sandbox


  1. Click on Runner options at the top and make sure the Wine version is System (5.0). Un-Enable D9VK as its merged into the DXVK libraries now (thanks AlexC) Click the Save button.


  1. Now you can just select Steam and click play and even make a desktop shortcut or app shortcut.


That is all folks.

Credits to Alleviate on the old forum

1 Like

All of that sounds… quite out of date, but basically it’s a long-winded way of saying:

  • Install the WineSteam install script from Lutris
  • Add CoD4 as a non-Steam game, install CoD4x through cmd/copy the files to AppData/Local/CallofDuty4MW as the script does.
  • Launch through WineSteam’s non-Steam game shortcut.

Unfortunately, while I had a WineSteam instance running for a source mod earlier, WineSteam looks to be unreasonably picky about running and now (seemingly) crashes out on launch as soon as the library window appears.

In theory, couldn’t CoD4x be made to work with the piecemeal steamclient libraries that Proton prefixes come with?
tbh, from a mere user’s perspective, I’m not even sure why Steam’s become a requirement–but I guess that’s besides the point now…