COD4x launcher crash, will not go to the MP menu

Multiplayer loading problem here:
Windows 10, latest updates etc. ALL Drivers sound/video accounted for and updated.

I will open steam, click play, select multiplayer, and the
“Call of Duty 4 X launcher will close now. restart cod4 if needed”
pops up EVERY time and I’m not able to get to the MP screen at all.

If I use the manual uninstall.cmd script in the folder for the 21.1 version I can get to the MP game screen but of course the server browser is all jazzed and shows almost less than 1k servers etc.

Steps I’ve taken:
Delete the game by uninstalling through steam
deleted ANYTHING related to the COD4 game from steam
deleted this folder C:\Users*\AppData\Local\CallofDuty4MW
shut off steam entirely. and re-downloaded the game entirely
then re-downloaded the latest 21.1 version from THIS SITE
reinstalled the whole thing and same problem no matter what I do.

My guess is this must be a registry issue? if so please advise, and if not:

HOW do I fix this?
Thank you for your time

ADDITION: when this happens I get a new IMPURE iw3mp.exe file created. even with a fresh STEAM download… hopefully this sheds some light on this issue. Thank you.

Steam version has a 1.8 update that doesn’t work with Cod4x as far as I know. So you need the 1.7 version of the iw3mp.exe file.
Check this YT video:

1 Like

I appreciate the reply, however I’ve been using the 1.8 steam version since it came out WITH cod4x as this mod/cod4x properly converts the steam version to work and puts it back to the proper 1.7, as well as adds the DLL files and other stuff for COD4x’s backend, aND download crash fixes etc. For whatever reason my COD4x install doesn’t work properly as it has been, which is what I’m inuring about above.

This video looks like it is if you’re NOT using cod4x, just just the stock steam version. I used to use the Retail copy (from my retail COD4 disc I bought in 2008) of the iw3mp.exe 1.7 file for YEARS before COD4x was a thing. Cheers!

Thank you for taking the time!

I have an update.

I went to the iw3mp.exe file, right clicked, clicked properties, and ran it as an administrator.

Turns out that COD4x was trying to update the iw3mp.exe file, but couldn’t as it did not have administrator privs… so each time it tried, it would create a “impure” file and start over again causing the “loop” I described where it would never get a chance to run the multiplayer aspect of COD4.

By right clicking on the iw3mp.exe file manually, (after running the cod4x manual install *.cmd file) and running it as an administrator just once, the file was updated properly and cod4x works properly now

Hope this helps someone else!

Glad you sorted it :+1:

1 Like

Definitely me too I was so frustrated. I run many full conversion mod cod4 servers already that not being able to get into them was a drag. Thanks for your time and positive presence on this one I appreciate it!