Unable to open in-game console

Both ` and ~ don’t open the console for me. I enabled the console before updating to CoD4X and it seems the option is now gone from the settings. I have tried changing the keyboard binding to a different key (e.g. the letter V) but that doesn’t help.

As a workaround I distinctly remember being able to launch an external console window in the past by adding some parameter to the startup command but I can’t remember how for the live of me and I can’t find anything about it either. Does anyone remember how to do that?

Shift ~ opens the console for me

1 Like

That’s nice for you but it doesn’t for me. Not sure what the point of your comment is tbh

If you open your config_mp.cfg file

Have a look at the code
mine starts with
// generated by Call of Duty, do not modify
bind TAB “+scores”
bind ESCAPE “togglemenu”
bind SPACE “+gostand”
bind 4 “+smoke”
bind 6 “+actionslot 4”
bind 7 “+actionslot 2”
bind ` “toggleconsole”
bind A “+moveleft”
bind B “mp_QuickMessage”
bind C “gocrouch”
bind D “+moveright”
bind E “+leanright”
bind F “+activate”
bind G “+frag”
bind N “+actionslot 1”
bind Q “+leanleft”
bind R “+reload”
bind S “+back”
bind T “chatmodepublic”
bind V “+melee”
bind W “+forward”
bind Y “chatmodeteam”
bind Z “+talk”
bind ~ “toggleconsole”

as you can see bind ` “toggleconsole” and bind ~ “toggleconsole” are the ones for console

if they are missing then add the lines

you find your config here:
C:\Users\your username\AppData\Local\CallofDuty4MW\players\profiles\your ingamename

You might have to choose view hidden items in explorer to show the appdata folder

As I already said in my initial post I have already tried changing those, but it makes no difference.

Also since I’m playing on Linux don’t paths are not correct, but don’t worry I know where the config file is :wink:

At least I found the option to open an external console on game launch, +sysconsole. However it only appears for a second or so and it closes again before the game has fully launched…

Did not know you are on Linux, hope you get it sorted