Where is everybody

is there nobody running this now? Nobody is answering, none of the past info is available, whats up with this? I cannot get any answers to anything.

This is the first time RGBMF has posted — let’s welcome them to our community!

“I cannot get any answers to anything”

but this is the first time you have posted on here :rofl: :rofl: :rofl:

1 Like

So there is somebody here! Sorry and YAY! Can somebody kindly tell me why I am getting a invalid token error on my server? I have replaced it with a new token several times, and still get the error?

:rofl: :rofl: :rofl: :rofl: :rofl:

Oh Dear…

Did you browse the forum?

Maybe this can help. Server Auth Token - Invalid - #10 by warrior

Thanks for replying guys! I have read as much as is available in the forums, and its not much. Heres the error, sv_authtoken is invalid! Abandoning master server registration. I have the sv command in the Global Config like this, set sv_authtoken “my config”. Do i have to register with COD4x or something?
THANKS for the help…

Make sure that the token is complete…sometimes if you copy/paste maybe miss a digit for example.

You mention Global config…You mean the server.cfg ?? (where it should be) I personally put the token in my start up command line. + set sv_authtoken “MYTOKENHERE” either way works.

You could also try deleting your token and creating a new one. That will disable the old one of course.

Should be straight forward and easy. As long as you have a clean and unlimited Steam account all good.

1 Like

Everything is verbatim, I tried moving to the command, but that didnt work either.
Does this look right?
Sending master heartbeat from to
Sending master heartbeat from to
cod4master.activision.com resolved to

No does not look right. The ‘to’ IP addresses are ok but…

the ‘from’ should be from your rented server IP address or a Local IP like 192.168.X.X for example (like mine) if you are using your own Server in your own Network.

Is this your own server? Or rented.

The ports need to be open in router (28964 in your case)

In your start up do you have these correct +set net_ip XXXXXXX +set net_port 28964

Also have +set dedicated 2 and +set sv_pure 1 in the start up. Not sure that make a difference in this case but just FYI.

NFO Servers, and yea, its in there and the +net ip and port too. And the “TO” is not mine, its changing to that. Weird! I can see and join the server, just cannot get the freakin token to register.

Do you have auth libs installed in the root directory?

steam_api.so and steamclient.so I am not 100% sure of there functionality but for sure you should have the steam ones in and I think libstdc++.so.6. libgcc_s.so.1 I am not sure if needed but I kept it in anyway.

2022-08-08 18_45_40-main-server-files - cod4server@fmjcod4.com - WinSCP

Maybe someone with a bit more know how can elaborate. I am not totally sure with it. Sorry.

Where are these files, I cant seem to find them?

They should be in your CoD4 Root directory where the main server files are. Not inside ‘Main’ but in that root.

Same directory as cod4x18_dedrun

I run a windows cod4 server on my network and I don’t have any of these files

only ones that are remotely similar are:


Seing that you are renting from NSO and they use a control panel to access and get your server working why not ask them… send their support a question. There will be a server start command line within the control panel… I would start there



1 Like

Thanks Mad, the server is running, i can connect to it, but I cannot get the token to work. Heres what i get…sv_authtoken is invalid! Abandoning master server registration
Sending master heartbeat from [::]:28964 to [2001:41d0:a:37ad::17]:20810
sv_authtoken is invalid! Abandoning master server registration
Sending master heartbeat from [::]:28964 to [2a02:730:1220::187]:20810
As much as I love NFO, they cannot help with this, its a error on my part, within the server software, and I cannot figure it out. But good thinking…I appreciate ANY and ALL info!

ah ok.

have you set the set sv_authtoken “your long token” in the server config?

Yes sir…like this
//CoD4X Global Config
set sv_authtoken “5FE348F2D38FAKETOKENFB7233DB48258EF24411”
set sv_masterservers “*cod4master.cod4x.ovh;cod4master.ax-servers.hu;”
set cl_updateservers “http://cod4update.cod4x.ovh/clupdate/
set cl_filterlisturl “http://filter.cod4x.ovh/filter/
set cl_cod4xsitedom “cod4x.ovh”
set sv_updateservers “http://cod4update.cod4x.ovh/svupdate/

to test if the token is being sent from config if you have set it -

go to your server console and enter it there
set sv_authtoken “jefhnowehfgowhegfowhgowghow”
change it to yours

never quote your token … for your eyes only